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Basic Operation of Soundshaper / CDP

INTRODUCTION

CDP (Composers’ Desktop Project) is a large suite of sound-transformation tools aimed
principally at composers of electro-acoustic music and sound designers.  Its basic mode of
operation is to take a file, process it and write another file.  The results are always non-real-
time: you can’t change sounds while they’re playing.  (Arguably, with the increasing speed of
computers, CDP already runs faster than real-time.)

Soundshaper also follows this basic pattern: choose a SOURCE sound, select a PROCESS, set
some PARAMETERS, click OK and then audition the result. If you want to change it, a simple
double-click takes you back to the parameter page to alter your settings. Soundshaper uses
temporary files, but you can save the result to a permanent file or continue to add further
processes. You can also save the whole sequence of processes as a PATCH.

SIMPLE OPERATION

Selecting a Source

Use the white file-selector icon or the File menu to select a source sound-file:

The source should be a standard .wav or .aif file, such as Windows 16-bit .wav . (For details, see
p.8 Soundfile Formats.)  You should normally be able to play the sound using the transport
controls for the built-in player:

Selecting a Process

The simplest way to select a process is to use one of the Process Menus. For example, the
process REPEATS is found in Soundfiles>Extend/Reorder:



There are five process menus::

• Edit/Mix and Soundfiles operate directly on the sound waveform;

• Spectral processes the information in the various frequency bands analysed in the sound;

• Pitch processes pitch information extracted from a spectral analysis;

• Info calls supporting functions, most of which give information about a (sound) file . The output does not
appear on the grid, but is sent to the Report Window or to a text file.

Alternative selection is by the Process Grids, the Processes list and keyboard shortcuts.

Parameter Page

Selecting a process normally leads to a Parameter Page. For REPEATS, we need to set two parameters: the
length of the segment we want to repeat (SEGDUR) and how many times to repeat it (REPEATS).

When this is done, click OK to run the process.

On return to the MAIN page, the process should be shown in Cell A_1 on the Patch Grid (1).
It’s also ready to play via the transport (2): click the arrow or hit the Spacebar:

Saving Files

If you press (or have pressed) the Save To button (3), you’ll see the Save Panel with a simple
editable name for saving the file. Click the folder icon (4) if you need to change the folder to
save it to. Click the Save button to save it to your chosen name. (Alternatively, you can save
files by clicking the floppy-disk icon in the toolbar above the Save Panel; this uses a standard
Windows Save Dialog.)   If you’re working with single processes, you might click the Clear
button (5) to clear the grid, then the New Source button (6) to make your saved file the new
source. (This is not actually recommended practice: it’s easier just to select a new process.)

Alternatively, you can save all processes in the Patch Grid by clicking on the Patch Save
button (7) – for details, see Saving and Loading Patches, below.
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WORKING WITH PATCHES

The Patch Grid

Soundshaper is organized around a multi-process Patch Grid.  Each row represents a separate
chain of processes: cells A_0 to A_12;  B_0 to B_12 etc. The rows can also be linked in various
ways.

The sources and process sequence on the grid are collectively called a Patch. Patches can be
saved, re-run, imported, etc. – see below.  A Patch can be as little as one processed cell, one
row, or several linked rows.

You can navigate around the grid using arrow keys, or by clicking on a cell. The current cell is
"highlighted" by special text around the row name (e.g. A>>) and column number (e.g. <4>) –
see cell A_4 above.

Occupied cells are coloured according to their file type (see CDP File types and Auto Conversion
below).  At any stage, you can click on an occupied cell and play it  (except for certain file
types), save it to a permanent file, get information about it, or view it in an external soundfile
viewer/editor.

The zero column is a source cell: start by clicking on A_0 or B_0, etc. (if not already highlighted),
then select a soundfile as a source.  The source file is copied to the source cell as a temporary
file (.wav format). If the cell is already occupied, the new source will replace it.

When you've run a process, it appears in the next free cell in the current row. For example:
select a source for A_0; processed output is shown in A_1. Select the next process: A_1 is
transformed into A_2, and so on.  Processing is always from left to right: from the last occupied
cell in the current row to the next cell to its right. The program always processes the last cell of
the currently selected row.

Various buttons relating to the Patch are just above the grid: Load/Save patch, Run etc.:

Common patch operations:

• To re-edit parameter values, double-click on the cell (or F8 if it was the last process).

• To delete the last process in the current row, use UNDO (CTRL+Z).

• To replace a process that's not at the end of a row, click the REPLACE PROCESS button:
the cell is cleared;  choose and run a replacement process, then click the RUN button to run
the patch again from that cell.

• To change a source, click on the source cell (e.g. A_0). Select a new source. Click RUN (or
RUN with Single-Row checked, to re-run just the current row.)

• Copying a cell: click on the cell you wish to copy; click START (or Alt+C); click on an empty
destination cell. Virtual copy is a cell splitter: if this is not checked, an actual copy is made.
For example: A_0 copied to B_0; process B_0   B_1. If B_0 is an actual copy, B_1's source is B_0;
if it’s a virtual copy, its source is A_0.
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Saving and Loading Patches

Much better than saving individual files is to save a Patch.  The patch represents a complete
history of what you processed, in a way that can be re-edited and run with different sources.

• Click the Patch SAVE button to save the current patch. Un-check "Include Sources" if you do
not want to save the source files.  If “Save All Files” is ticked, each processed cell’s file is also
saved within the patch folder.  Patches are stored by default in <User-folder>\Patches.

 • Click the LOAD button to load and run a pre-saved patch. Un-check "Include Sources" if you
intend to run the patch with a different source. Check "Patch Preview" to load but not run the
patch, followed by RUN if required.

If no sources were saved with the patch, you will be prompted to supply source files for certain
rows. However, the source’s path is saved as part of the patch data, so if the source still exists,
it is loaded and run.

CDP FILE TYPES and AUTO-CONVERSION

Almost every process in CDP reads from one file and creates another, and CDP uses several
different file types. In Soundshaper, you can generally ignore these and simply choose a
process, allowing Soundshaper to convert between file types behind the scenes.

Soundshaper shows the native input file type beside the menu item, using colour coding:

Text data files are also commonly used, especially two column "breakpoint" files (.brk)
representing TIME and VALUE, for time-varying data.

Auto-Conversion

Soundshaper auto-converts file types as follows:

For example, if the native file-type is Formant and you select a Sound file, Soundshaper will
convert Sound - Spectral - Formant, using the current default settings. Spectral - Sound is the
only backwards auto-conversion, and this is done for every spectral file (.ana) if the option
Auto-FFT is set (see Options menu). The function MAKE is used to combine .frq and .for files
to make a spectral file (.ana). Note that transposition files (.trn) are not auto-converted.

SPECTRAL(.ana)

ENVELOPE (.evl)

ENVELOPE (.brk)

PITCH (.brk)

FORMANT (.for)

PITCH (.frq)SOUND (.wav)

White Soundfiles (.wav)
Aqua Spectral analysis files (.ana)
Fuchsia Pitch files (.frq, derived from .ana)
Green Formant files (.for, derived from .ana)
Lilac Transposition files (.trn, derived from .frq)
Red Envelope files (.evl, derived from .wav)



Secondary Input Files

When a process requires or can have secondary inputs, the process menu icon shows two files
for a second input or multiple files for multiple inputs:

On selecting the process, a red panel appears in the top left-hand corner of the Main Page,
labelled ADD INPUT:

If the input is from another cell in the grid, just click on that cell; Soundshaper makes any
necessary auto-conversions as required. (If auto-conversion is not possible, you must add a cell
which does it specifically.)  The selected input is added to the drop-down box.

It is also possible to select a file in the normal way via a File Selector icon or the File menu: the
file is then copied to your temporary soundfiles folder with the same name. However, auto-
conversion from this file will not work; for this reason, it is better first to load the file to a source
cell if possible.

Optional Inputs

If secondary inputs are optional, the panel is labelled OPTIONAL INPUTS.  If you don’t want to
add any, click OK to run the process without them. (Examples: Texture and Grain)

If multiple inputs are possible, the second one may be compulsory in some cases (e.g. Spectral
Interleave). Any further inputs are always optional.

CHANNELS

A key aim of Soundshaper is that a patch should be able to be run with any source file(s),
irrespective of the number of channels in the source. From Soundshaper 4.4, new batchfile
scripts cater for mono, stereo and multi-channel inputs to all but a handful of processes.

The scripts perform channel conversion as necessary behind the scenes. For stereo and multi-
channel files presented to mono processes (including the whole of the spectral suite), they split
the file into separate channels, process each channel and interleave them again.

For several mono-only and stereo-only processes, the input file may have to be converted to the
correct number of channels. In this case, the original is preserved and re-instated after
processing.

Separate channel processing

Soundshaper (from 4.1) now offers separate processing for each channel (wherever possible).
Tick the Multi-Params checkbox on the Parameter Page and store each set of parameters using
the snapshot buttons (1-8 for up to 8 channels). If a snapshot is unoccupied, the previous
snapshot is duplicated; for example, saving to snapshots 1 and 3 only for a 4-channel file will
duplicate snapshot 1 for channel 2 and snapshot 3 for channel 4.
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EXTERNAL VIEWER / EDITOR

Soundshaper does not have its own soundfile viewer, as there are many good editors on the
market.  Two free ones that are currently recommended are AUDACITY and WAVOSAUR .

• On the Settings page, select your default soundfile viewer/editor:

This is normally done in advance of running the program, and stored in Soundshaper’s
configuration file Soundshaper.evt.

• To send the soundfile from any highlighted cell to the external viewer/editor, hit F2 or click on
the viewer/editor icon in the toolbar:

• Soundshaper can get markers (cue points) set in Audacity, Wavesurfer, or CDP’s VIEWSF,
which can be used to cut the file for processing part of the sound (see Manual: Main Page-Other
> Markers).  Unfortunately, Wavosaur does not seem able to export markers at present.

• External processing can be done in the Viewer/Editor. Both Audacity and Wavosaur are VST
hosts. Save the results to the current cell-file. If this is a NULL file, it has no CDP processing of
its own, but can inherit the result of the external process.

• It’s best to close the Soundshaper Player before doing any processing in the Viewer/Editor, so
that the file is not already open: click the icon in the toolbar or select Tools>Close Soundfile
Player [Ctrl+F10].

• Similarly, close the file in the Viewer/Editor after use to avoid any conflicts with Soundshaper
subsequently attempting to save to an open file (I/O ERROR 32).

Other External Programs

Other favourite programs are accessed via Tools > Favourites  (for details see see Manual:
Main Page - Other > Favourites).
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TIME-VARYING DATA

Many CDP parameter values can vary over time, typically over the length of the input file.  On
the Parameter Page, check the box marked “T-V” if available. The edit box displays a default
filename (within your User Folder), instead of a numerical value:

If this file already exists, its data is shown in the Datafile Edit Box, which is also displayed (for
the current parameter):

All datafiles in CDP are text files and most are “breakpoint” files of TIME and VALUE (as in
rate.brk above).  In CDP breakpoint files, all values vary linearly between one time and the
next; in the above example, the value at time 3” would be approximately 8.0. (To keep a value
static, add a later time-point with the same value as the one above it.) Time values must be in
(at least minimally) ascending order and are always in seconds.

Soundshaper now comes with a comprehensive set of default datafiles, which you can use as
the basis for your own values. The Scale button (1) re-scales all time values proportionately to
the length of the current file, so they can easily be customised. There is also an Auto-scaling
option. Clicking the Edit button (2) displays the data as a graph (normally choose IMPORT
from the display options), which is also simple to edit visually (see Manual: Graph-Edit), or
manually in a table:

Before running or after editing, the datafile is saved to a temporary file of the same name (this
is necessary to keep patches self-contained). So unless you deliberately over-write the original
data file (either the template or another you have opened), it is preserved for future use.
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SOUNDFILE FORMATS

All source soundfiles are converted to .wav format before processing.

.Wav or .aif sources are supported; formats such as Ogg Vorbis, FLAC, and mp3 are not.

Many different types are supported, especially within .wav. For details see the documentation
for Richard Dobson’s Multi-channel Toolkit in the CDP Documentation.

In Options > Settings, you can pre-select either 16 (integer) or 32 (floating point) as the
sample type.  “16” also refers to 24-bit Integers, as the difference is really between integers
and floats, not the bit-rate. Irrespective of the source file, the internal copy is either integer or
float,  depending on which type you have selected.   If you select “16”, the internal .wav file
will be an integer type, but the actual bit-rate and sample-rate of the original are preserved,
since CDP functions in general output the same format as the input.

I have personally tested* the following internal .wav formats:

* Tests: a simple soundfile process, PVOC analysis (to spectral file), spectral process , PVOC synthesis (to
soundfile).

Integer 16-bit 44.1Khz Mono / Stereo (i.e. CD standard)/ Quad WAVEX
Integer 16-bit 44.1Khz Quad Standard (playback via CDP player only)
Integer 24-bit 44.1Khz Stereo
Integer 24-bit 48 Khz Stereo
Integer 24-bit 96 Khz Stereo
Floating-Pt 32-bit 44.1Khz Mono / Stereo / Quad WAVEX
Floating-Pt 32-bit 44.1Khz Quad Std. (playback via CDP player only)
Floating-Pt 32-bit 48 Khz Stereo
Floating-Pt 32-bit 96 Khz Stereo


